Firmware: Chameleon (1.0.41) Firmware [18 APR 2016] | Gecko (20151106) Firmware [13 NOV 2015]


Post Reply 
How to manually change the time?
01-09-2016, 06:48 PM (This post was last modified: 01-09-2016 06:51 PM by Auggie.)
Post: #1
Question How to manually change the time?
This should not be hard.

I've tried setting up my Gecko to automatically adjust the time (Settings->General->Advanced->Date & Time: Automatic date & time plus Automatic time zone checked) but sets the time 6 hours ahead of where I'm at.

I uncheck both automatic options and manually set my time zone (CST, -6:00 GMT) but the time is still incorrect. The time does change according to whichever time zone I select, but the time clock is definitely wrong.

How do I manually change the time?

BTW, when I look under Settings->General->Advanced->Location->Location Services->Google Location Reporting->Location Reporting, it's set to "Off for this device." I can't figure out how to enable it.
Find all posts by this user
Add Thank You Quote this message in a reply
01-10-2016, 03:02 AM
Post: #2
RE: How to manually change the time?
I also noticed that every time I power up the Gecko, the time always starts up as 6 AM. It doesn't matter if the Automatic time settings are checked or not. It eventually changes after a minute or so to whatever time it thinks it is (remember, I can't figure out how to change the time).

Pretty annoying.
Find all posts by this user
Add Thank You Quote this message in a reply
01-10-2016, 05:56 AM (This post was last modified: 01-10-2016 06:00 AM by Auggie.)
Post: #3
RE: How to manually change the time?
A little more digging:

There appears to be a bug with the "Select time zone" setting: Any negative offset, that is, any selected zone that is less than GMT -3:00 is ignored completely and the time is displayed at GMT with no offset.

And positive offsets may or may not work. GMT +2:00 sometimes did not work, but GMT +6:00 did. Perhaps it's with the particular city associated with an offset, such as GMT +2:00 Cairo worked, but GMT +2:00 Windhoek did not. But I'm not going to waste my time trying all the available offsets when I already know that the system is broken as-is.

In addition, it may take a few moments or even minutes before any zone changes takes affect. Just more frustration piled on...
Find all posts by this user
Add Thank You Quote this message in a reply
01-10-2016, 02:05 PM (This post was last modified: 01-10-2016 02:14 PM by chris57.)
Post: #4
RE: How to manually change the time?
I dont get this. My gecko starts at 0.00 , the gmt setting for my location, then it connects via my router and updates the time.

As i'm on GMT i wouldn't but you are the first to mention it.

My settings are Automatic Date and Time Ticked, Automatic time zone unticked, select time zone gmt +0.00, use 24hr ticked, dd/mm/yy selected.

If i untick the network top two options and select yanisberg +6 my gecko adds six hours and the time is gmt+6. You have to give the ui chance tp update, took ten seconds or less.
I then do the same for gmt-6 with the same result, my ui clock now shows gmt-6.

My location is set to ON. You have to set it in google when it first asks when you add a gmail account to any android device iirc.

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
01-10-2016, 02:25 PM (This post was last modified: 01-10-2016 02:31 PM by Auggie.)
Post: #5
RE: How to manually change the time?
(01-10-2016 02:05 PM)chris57 Wrote:  If i untick the network top two options and select yanisberg +6 my gecko adds six hours and the time is gmt+6. You have to give the ui chance tp update, took ten seconds or less.

Something must be different in the firmwares between our Gecko's because as I stated, certain offset selections just don't work on mine for some reason. I really don't care too much if the time is inaccurate because these media players don't usually do any time-stamping or other time-sensitive operations (on the C-200, you have to press a remote button to bring up the time, which is displayed only momentarily), however, since the time is always prominently displayed on the main launch screen, it's annoying to see the wrong time. It's like coming across a home electronic device that has a clock at someone's house and seeing it flash or have the wrong time because the user just doesn't know how to set it.

(01-10-2016 02:05 PM)chris57 Wrote:  My location is set to ON. You have to set it in google when it first asks when you add a gmail account to any android device iirc.

I already tried Google's stated method of setting the Location, which BTW I've set to "High accuracy" GPS, Wi-Fi, and mobile networks, but when I go to Location Reporting it has both to "Off" but there is no way I can figure out to change it, even following Goggle's instructions.

And I've given it plenty of time to allow time-zone correctly, but frankly, because it's a user selected setting and it's really just a mathematical operation, it should be instantaneous: there should be no reason for a delay once a time-zone offset is selected by the user.

Of course, if everything is on automatic, then yes, it may take some time for the system to determine its location and time-zone; but not when everything is set to manual.

Anyways, I currently have automatic date & time enabled but automatic time zone disabled, and have managed to get a GMT -4:00 offset to work (actually, it's set to "GMT -3:00, Chile Summer" so in reality, this is yet another bug because the actual offset applied is -4:00), so at least my time is off by only 2 hours, instead of 6.
Find all posts by this user
Add Thank You Quote this message in a reply
01-10-2016, 02:36 PM (This post was last modified: 01-10-2016 02:38 PM by chris57.)
Post: #6
RE: How to manually change the time?
I used Central America -6.00 and it worked. Build number Gecko 20151106. 105540. kernel 6 nov.

Set me a timezone challenge that you can't get updated?

On location, when the location cog is highlighted press right twice to get to on/off. press ok turns on/off on my android settings.

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)