Firmware: Chameleon (1.0.41) Firmware [18 APR 2016] | Gecko (20151106) Firmware [13 NOV 2015]


Post Reply 
Fails to play Dolby TrueHD tracks in both android and optimized KODI media players.
10-15-2015, 11:22 PM (This post was last modified: 10-15-2015 11:23 PM by mishastr.)
Post: #1
RE: Gecko Bugfix Requests
Fails to play Dolby TrueHD tracks in both android and optimized KODI media players.
Find all posts by this user
Add Thank You Quote this message in a reply
10-16-2015, 07:49 AM (This post was last modified: 10-16-2015 07:51 AM by Willem55.)
Post: #2
RE: Gecko Bugfix Requests
(10-15-2015 11:22 PM)mishastr Wrote:  Fails to play Dolby TrueHD tracks in both android and optimized KODI media players.

not confirmed check a 4,37




Some focus on problems and faults others on solutions and success... no question who is the happy one.

Chameleon 16GB SD 32GB micro SD <-->HDMIv1.3<-->Onkyo TX-NR1010<-->HDMIv1.3<-->Panasonic TX-P46S10 + 6 Bowers & Wilkins speakers.
10 NTFS 2TB USB drives on 3 hubs attached to a A400, 2 Seagate blackarmour NAS 3TB, 2 Seagate Central NAS 4TB.
Find all posts by this user
Add Thank You Quote this message in a reply
10-16-2015, 03:21 PM (This post was last modified: 10-16-2015 03:23 PM by mishastr.)
Post: #3
RE: Gecko Bugfix Requests
Should I post a video too?
Mad Max Fury Road BD - silence on Dolby TRUE-HD track
OpenELEC (raspberry PI-2) - plays this track perfectly ( the same setup)
Where is the problem?
_____________
HDMI sound - RAW
In Kodi settings the same as in OpenElec (I think )
Find all posts by this user
Add Thank You Quote this message in a reply
10-16-2015, 03:26 PM (This post was last modified: 10-16-2015 03:30 PM by Willem55.)
Post: #4
RE: Gecko Bugfix Requests
set RAW to Auto
It will only work in "Optimized" Kodi from Openhour...
If you want support from users about settings start a thread, don't shout "BUG"

Some focus on problems and faults others on solutions and success... no question who is the happy one.

Chameleon 16GB SD 32GB micro SD <-->HDMIv1.3<-->Onkyo TX-NR1010<-->HDMIv1.3<-->Panasonic TX-P46S10 + 6 Bowers & Wilkins speakers.
10 NTFS 2TB USB drives on 3 hubs attached to a A400, 2 Seagate blackarmour NAS 3TB, 2 Seagate Central NAS 4TB.
Find all posts by this user
Add Thank You Quote this message in a reply
[+] 1 user says Thank You to Willem55 for this post
10-16-2015, 07:40 PM
Post: #5
RE: Gecko Bugfix Requests
(10-16-2015 03:26 PM)Willem55 Wrote:  set RAW to Auto
It will only work in "Optimized" Kodi from Openhour...
If you want support from users about settings start a thread, don't shout "BUG"
Didn't help, the picture stays the same
It might be a bug actually.
I do not know what to think, since OpenElec works perfectly.
Find all posts by this user
Add Thank You Quote this message in a reply
10-16-2015, 08:49 PM
Post: #6
RE: Gecko Bugfix Requests
picture?.... we were talking audio..

Some focus on problems and faults others on solutions and success... no question who is the happy one.

Chameleon 16GB SD 32GB micro SD <-->HDMIv1.3<-->Onkyo TX-NR1010<-->HDMIv1.3<-->Panasonic TX-P46S10 + 6 Bowers & Wilkins speakers.
10 NTFS 2TB USB drives on 3 hubs attached to a A400, 2 Seagate blackarmour NAS 3TB, 2 Seagate Central NAS 4TB.
Find all posts by this user
Add Thank You Quote this message in a reply
10-16-2015, 08:58 PM (This post was last modified: 10-16-2015 09:28 PM by mishastr.)
Post: #7
RE: Gecko Bugfix Requests
(10-16-2015 08:49 PM)Willem55 Wrote:  picture?.... we were talking audio..
Figure of speech = "nothing has changed" Angel
I still listen silence instead of audio track
It looks like the device completely can not pass through this type of sounds tracks.
Find all posts by this user
Add Thank You Quote this message in a reply
10-17-2015, 08:22 AM (This post was last modified: 10-17-2015 08:23 AM by POPA110.)
Post: #8
RE: Gecko Bugfix Requests
Please send us a sample with MKVToolnix
Go to the split output section -> splitting

http://www.videohelp.com/software/MKVtoolnix
Find all posts by this user
Add Thank You Quote this message in a reply
10-17-2015, 11:15 AM (This post was last modified: 10-17-2015 11:19 AM by Willem55.)
Post: #9
Fails to play Dolby TrueHD tracks in both android and optimized KODI media players.
posts moved from bugfix request list for further discussion.

I will add a bugfix request if the facts are clear.

Some focus on problems and faults others on solutions and success... no question who is the happy one.

Chameleon 16GB SD 32GB micro SD <-->HDMIv1.3<-->Onkyo TX-NR1010<-->HDMIv1.3<-->Panasonic TX-P46S10 + 6 Bowers & Wilkins speakers.
10 NTFS 2TB USB drives on 3 hubs attached to a A400, 2 Seagate blackarmour NAS 3TB, 2 Seagate Central NAS 4TB.
Find all posts by this user
Add Thank You Quote this message in a reply
[+] 1 user says Thank You to Willem55 for this post
10-17-2015, 12:19 PM (This post was last modified: 10-17-2015 12:20 PM by couto27.)
Post: #10
RE: Fails to play Dolby TrueHD tracks in both android and optimized KODI media players.
Confirmed TrueHD audio doesnt play in:

American sniper
Mad Max Fury Road
More to come...
Find all posts by this user
Add Thank You Quote this message in a reply
10-17-2015, 04:46 PM (This post was last modified: 10-17-2015 04:46 PM by Willem55.)
Post: #11
RE: Fails to play Dolby TrueHD tracks in both android and optimized KODI media players.
yes same more to come as 10 days ago, question is what makes these 2 RIPs fail cause the issue is not TrueHD fails but some TrueHD rips fail.
is it an ATMOS track perhaps..?
bad header that works fine in software playback but fails in hardware..?
does any have a MediaInfo report for these failing TrueHD files?

Some focus on problems and faults others on solutions and success... no question who is the happy one.

Chameleon 16GB SD 32GB micro SD <-->HDMIv1.3<-->Onkyo TX-NR1010<-->HDMIv1.3<-->Panasonic TX-P46S10 + 6 Bowers & Wilkins speakers.
10 NTFS 2TB USB drives on 3 hubs attached to a A400, 2 Seagate blackarmour NAS 3TB, 2 Seagate Central NAS 4TB.
Find all posts by this user
Add Thank You Quote this message in a reply
10-17-2015, 05:49 PM (This post was last modified: 10-17-2015 06:39 PM by mishastr.)
Post: #12
RE: Fails to play Dolby TrueHD tracks in both android and optimized KODI media players.
Yes they are ATMOS
It's not a rip it's a BD ISO Confused
"Mad Max Fury Road"
"Jupiter Ascending"
Please look into PM for more details
This forum does not allow me to post media info
I always get notification about too many URLs in my post
Find all posts by this user
Add Thank You Quote this message in a reply
10-17-2015, 08:42 PM
Post: #13
RE: Fails to play Dolby TrueHD tracks in both android and optimized KODI media players.
Sounds like its going to be another ATMOS/truehd. I will check out San Sndres later tonight to see if I get truehd out of it. As All the confirmed are ATMOS movies
Find all posts by this user
Add Thank You Quote this message in a reply
10-18-2015, 12:52 AM
Post: #14
RE: Fails to play Dolby TrueHD tracks in both android and optimized KODI media players.
Look s like it, but there's nothing better than a sweeping generalisation that all TrueHD tracks dont work.Big Grin

It's time to stop, read what has been requested (mediainfo output, test files) and put forward a detailed report to enable reproduction in the lab so that a fix can be worked on instead of putting zero effort into that and being more interested in crying bug or bias. Moved completely OT post into the OT section. This is a diagnosing thread not a personal attack thread on those that wont be bullied. Get back to basics if you want to be taken seriously again after your earlier behaviour.

@ mishastr thanks for getting the message and now working on helping identify the issue.

BDInfo can scan full BDMV or BD ISO files to give an output but not sure its ATMOS compatible. Otherwise Mediainfo but its only really for single filetypes.

Do the files play using the Media Center on the Home Page, big green icon?

What happens if you download TrueHD files and try to play then:
http://www.demo-world.eu/2d-demo-trailers-hd/
there they have :
TrueHD 5.1
TrueHD7.1
TrueHD 7.1 +ATMOS
Etc.

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
10-18-2015, 01:39 AM (This post was last modified: 10-18-2015 01:40 AM by POPA110.)
Post: #15
RE: Fails to play Dolby TrueHD tracks in both android and optimized KODI media players.
(10-16-2015 03:21 PM)mishastr Wrote:  Should I post a video too?
Mad Max Fury Road BD - silence on Dolby TRUE-HD track
OpenELEC (raspberry PI-2) - plays this track perfectly ( the same setup)
Where is the problem?
_____________
HDMI sound - RAW
In Kodi settings the same as in OpenElec (I think )

I have tested your file and play fine after remux video

Maybe problem identification codec ID file

Quote:Vidéo
ID : 1
Format : MPEG-4 Visual
Format settings, BVOP : Oui
Format settings, QPel : Non
Format settings, GMC : Pas de warppoints
Format settings, Matrix : Default (H.263)
Codec ID : V_MS/VFW/FOURCC / DIVX
Codec ID/Info : Project Mayo
Codec ID/Hint : DivX 4

Sample File remuxed with mkvtoolnix play fine with gecko
http://www.mediafire.com/download/4q49tm...D2-001.mkv
Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Kodi update? grimmace92 1 911 08-12-2016 03:41 PM
Last Post: Jokerchyld
  Soon-to-be New Gecko owner: Any install, "jukebox" and media player setup tips? Auggie 26 6,906 01-12-2016 07:00 PM
Last Post: chris57
  Kodi not on 2160p Locutus75 16 6,125 12-19-2015 05:45 PM
Last Post: Locutus75
  Resume bug (and others) in Kodi Locutus75 6 2,425 12-13-2015 03:24 PM
Last Post: Locutus75
  No playback in Kodi with hiplayer and SMB shares chris57 11 4,823 10-14-2015 01:52 AM
Last Post: chris57
  Android Settings - missing or suggestions chris57 0 554 10-06-2015 12:16 PM
Last Post: chris57

Forum Jump:


User(s) browsing this thread: 1 Guest(s)