Firmware: Chameleon (1.0.41) Firmware [18 APR 2016] | Gecko (20151106) Firmware [13 NOV 2015]


Post Reply 
No playback in Kodi with hiplayer and SMB shares
10-06-2015, 02:21 PM (This post was last modified: 10-06-2015 03:30 PM by chris57.)
Post: #1
No playback in Kodi with hiplayer and SMB shares
Hi

I can delete and playback using DVD Player my MKV and other files however none will play using the hiplayer(default) option.

Don't want to set the non-default DVD player to play permanently but it needs resolving. I'll have to grab logs.

Anyone else having a problem. Seem one other poster so far.

Playback is from any SMB shares on my network. Can delete etc. so its not a permission issue unless somehow the hiplayer is not getting the login details.

Havent tested playback from non SMB shares or local yet.

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
10-06-2015, 09:52 PM
Post: #2
RE: No playback in Kodi with hiplayer and SMB shares
I have several files (mkv) that won't play with the default player in Kodi on the Gecko. The DVDPlayer seems to play the problem files okay.

A100, A110, A200, A200, A210, C200, A300, VTEN, Chameleon, Gecko
Dune D1, Dune HD
Find all posts by this user
Add Thank You Quote this message in a reply
10-07-2015, 10:16 PM
Post: #3
RE: No playback in Kodi with hiplayer and SMB shares
I'm finding that using the DVD Player in Kodi gives sync issues on most files. Still cannot get hiplayer to work for me yet.

Using the MediaCentre for playback is giving me great results. The picture is really sharp and the onboard BD menu easy to operate and skip between playlists, chapters, audio tracks etc.

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
10-07-2015, 10:28 PM
Post: #4
RE: No playback in Kodi with hiplayer and SMB shares
(10-07-2015 10:16 PM)chris57 Wrote:  I'm finding that using the DVD Player in Kodi gives sync issues on most files. Still cannot get hiplayer to work for me yet.

Using the MediaCentre for playback is giving me great results. The picture is really sharp and the onboard BD menu easy to operate and skip between playlists, chapters, audio tracks etc.

That has been my observation too. So far, I have had any real issues with the Media Center player. It seems very stable.

I have an HDHomeRun Network TV Tuner and that plays quite well in Media Center.

It's a shame that Kodi has too many issues for now. I would like a the same look and feel across all of my devices.

A100, A110, A200, A200, A210, C200, A300, VTEN, Chameleon, Gecko
Dune D1, Dune HD
Find all posts by this user
Add Thank You Quote this message in a reply
10-08-2015, 02:09 AM
Post: #5
RE: No playback in Kodi with hiplayer and SMB shares
So far, I've only found one video file that won't play with the default Kodi player. AVC Video (High@L3.1, H.264, 29.970 fps), AAC 2.0 Audio. File is on my WHS box, accessing via SMB.

PopcornHour A-100 | PopcornHour A-200 | OpenHour Gecko | WHS 2011 (10TB Storage)
Find all posts by this user
Add Thank You Quote this message in a reply
10-08-2015, 07:32 AM (This post was last modified: 10-08-2015 07:56 AM by chris57.)
Post: #6
RE: No playback in Kodi with hiplayer and SMB shares
I dont think its down to file types as nothing will play on my setup with hiplayer. MKV with AAC, MKV with AC3, MP4 with AAC, BD ISO, BDMV, etc.

I did think is it something to do with the share naming as one of my shares has brackets and spaces in it and that did cause problems once before, however this time I've tested with SMB shares from my A400, Synology NAS, and the other location.

I would love to see the picture quality of the hiplayer Imprex video processing in Kodi. It would be perhaps the first time that I've thought Kodi PQ didn't look smooth on playback. Decent PQ in Kodi/Android.

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
10-08-2015, 04:14 PM (This post was last modified: 10-08-2015 06:11 PM by chris57.)
Post: #7
RE: No playback in Kodi with hiplayer and SMB shares
Took a Kodi log and started trying to playback both MKV and MP4 files using just the 'enter' key and also the menu select play with hiplayer:

Code:
16:08:36 T:1299168232   ERROR: HiSi - IPlay_init erro
16:08:36 T:1299168232   DEBUG: HiSi@HiPlayer.cpp:virtual bool CHiPlayer::OpenFile(const CFileItem&, const CPlayerOptions&)_ 373 OUT
16:08:36 T:1299168232   DEBUG: virtual void CApplication::OnPlayBackStopped(): play state was 1, starting 0
16:08:36 T:1299168232   DEBUG: CAnnouncementManager - Announcement: OnStop from xbmc
16:08:36 T:1299168232   DEBUG: GOT ANNOUNCEMENT, type: 1, from xbmc, message OnStop
16:08:36 T:1299168232   ERROR: Playlist Player: skipping unplayable item: 0, path [smb://RT-AC66U-C57/Download (at Seagate_Expansion_Drive)/Complete/Atlanta.Plastic.S01E06.HDTV.x264-CRiMSON.mp4]
16:08:36 T:1299168232   DEBUG: Playlist Player: one or more items failed to play... aborting playback

Full log here with playback starting at 16.08:
http://xbmclogs.com/pn7ll337e

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
10-12-2015, 08:05 PM
Post: #8
RE: No playback in Kodi with hiplayer and SMB shares
Used the MediaCenter saved SMB shares, add them to Kodi via root > mnt > smb > mountpoints

Playback using hiplayer now works in Kodi via this way and OH claim better performance.

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
[+] 1 user says Thank You to chris57 for this post
10-13-2015, 12:27 AM
Post: #9
RE: No playback in Kodi with hiplayer and SMB shares
(10-12-2015 08:05 PM)chris57 Wrote:  Used the MediaCenter saved SMB shares, add them to Kodi via root > mnt > smb > mountpoints

Playback using hiplayer now works in Kodi via this way and OH claim better performance.

This worked for me. Play back was successful on my problem files. However, it would be nice if the mounted shares would stay mounted after reboot.

A100, A110, A200, A200, A210, C200, A300, VTEN, Chameleon, Gecko
Dune D1, Dune HD
Find all posts by this user
Add Thank You Quote this message in a reply
10-13-2015, 09:35 PM
Post: #10
RE: No playback in Kodi with hiplayer and SMB shares
I wmder if you add them via add share rather than browsing if that makes them persistant, remaining after reboot?

We need a way for them to remain.

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
10-14-2015, 01:48 AM
Post: #11
RE: No playback in Kodi with hiplayer and SMB shares
(10-13-2015 09:35 PM)chris57 Wrote:  I wmder if you add them via add share rather than browsing if that makes them persistant, remaining after reboot?

We need a way for them to remain.

How does one go about adding an smb share?

I have tried ES File Manger and AndSMB, both do not seem to provide persistent shares.

A100, A110, A200, A200, A210, C200, A300, VTEN, Chameleon, Gecko
Dune D1, Dune HD
Find all posts by this user
Add Thank You Quote this message in a reply
10-14-2015, 01:52 AM (This post was last modified: 10-14-2015 01:55 AM by chris57.)
Post: #12
RE: No playback in Kodi with hiplayer and SMB shares
In the Media Center app you can add either by scanning and then selecting when it says add shortcut or you add a specific path etc. which has a Remember option to select.

I use SMBFileserver on the OHC but like all smb apps requires root access. Android is not as lan friendly as other os'.

This was an issue early in ohc development along with not remembering, then the remember got added and it fixed things so im hopeful oh can resolve it.

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Kodi update? grimmace92 1 921 08-12-2016 03:41 PM
Last Post: Jokerchyld
  3D-Playback Ernesto13 1 980 02-14-2016 07:50 PM
Last Post: Ernesto13
  Kodi not on 2160p Locutus75 16 6,171 12-19-2015 05:45 PM
Last Post: Locutus75
  Resume bug (and others) in Kodi Locutus75 6 2,442 12-13-2015 03:24 PM
Last Post: Locutus75
  Youtube Playback JimMc 10 3,915 11-27-2015 09:36 PM
Last Post: JimMc
  Fails to play Dolby TrueHD tracks in both android and optimized KODI media players. mishastr 21 7,914 10-19-2015 10:11 PM
Last Post: Willem55

Forum Jump:


User(s) browsing this thread: 1 Guest(s)