Firmware: Chameleon (1.0.41) Firmware [18 APR 2016] | Gecko (20151106) Firmware [13 NOV 2015]


Post Reply 
Problem running Android/Open Hour
09-10-2015, 04:39 PM (This post was last modified: 09-10-2015 04:59 PM by MichaelHeerlen.)
Post: #1
Problem running Android/Open Hour
Hello,

I recieve today my new Open Hour Chameleon, and it worked but I made one stupid misstake by install Kodi.. I did'nt found one usb so I tried to do install it on the SD from pc, and where so stupid to format the SD card..

Now I am busy to get it okay for an couple of hours but it all doesnt work, grr.

I think that the problem is that I removed the MAC code (wiki[dot]openhourlab[dot]com/index[dot]php/Burn_MAC_to_SD_Card).
I want to get the MAC code on it again, the programm upgadeDIItool said that he found it(the open hour chameleon is connected to the pc), but it's not possible to writing MAC, the program says ''writing mac failed!''.

I just can't get it.. But why?


Can someone help me? How do I get my formated SD correctly to start up my Open Hour Chameleon?

[edit]
Maybe is this te problem, I don't understand point 4. Go to Chameleon Android Advanced Settings => USB => enable/tick "Connect to PC". Then UpgradeDll Tool will show "Found one msc device".
Cause, I just can't find the ''Chameleon android advanced settings'', where can I find those?

Thanks,
Excuses for all typing faults, I'm Dutch Wink
Find all posts by this user
Add Thank You Quote this message in a reply
09-10-2015, 06:35 PM
Post: #2
RE: Problem running Android/Open Hour
You have to connect the OHC to the PC that is running the .exe using the OTG port on the rear of the OHC. Have you done that? Make sure that the PC USB port is not USB3, it MUST be USB2.0.

However as you have formatted the SD card you have totally erased the OS of the OHC. You must write the OS back on the SD card via this method:
http://wiki.openhourlab.com/index.php/Bu...d_and_back

The OHC advanced settings are in the UI once the OHC has booted into the Android OS. Bottom sections second from the left settings > Advanced Settings. You can also get there more directly sing another way as I once did it using my mele keypad which was quite a surprise Big Grin

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
09-10-2015, 07:10 PM
Post: #3
RE: Problem running Android/Open Hour
(09-10-2015 06:35 PM)chris57 Wrote:  You have to connect the OHC to the PC that is running the .exe using the OTG port on the rear of the OHC. Have you done that? Make sure that the PC USB port is not USB3, it MUST be USB2.0.

Yes, I did, and yes it is 2.0, I've tried 2 2.0 usb port's

Quote:However as you have formatted the SD card you have totally erased the OS of the OHC. You must write the OS back on the SD card via this method:
http://wiki openhourlab com/index php/Burn_OS_to_SD_Card_and_back

Also did this, but I don't saw anything on my tv. De light of OHC is on, but that's it. (I'd tried also one other HDMI cable, so that's not the problem.)

Quote:The OHC advanced settings are in the UI once the OHC has booted into the Android OS. Bottom sections second from the left settings > Advanced Settings. You can also get there more directly sing another way as I once did it using my mele keypad which was quite a surprise Big Grin

I don't understand. Maybe couse you tell me that I see it if I booted in Android, the problem is the OHC don't boot (I just don't see anything on my TV
Shall it give problem cause the MAC adress may not correct? I think so, but it failed to write the MAC adress...


I asked myself, why is installing of an OHC so difficult...
Find all posts by this user
Add Thank You Quote this message in a reply
09-10-2015, 09:17 PM (This post was last modified: 09-10-2015 09:18 PM by chris57.)
Post: #4
RE: Problem running Android/Open Hour
Forget the MAC issue as that is not what is causing you to not see anything on your screen when booting. You have borked the install on the SD card.

Have you or have you not formatted your SD card? If yes then you have to burn the firmware onto the SD card on a PC using :
Quote:1. Download the latest "Win32 Disk Imager" from http://sourceforge.net/projects/win32diskimager/ and install it on your PC.

2. Download the image file (e.g. [burn]_open_hour_chameleon_[OS]_[VERSIONS].zip) from Open Hour Chameleon SD Card Images to your PC and unzip it.

3. Plug in the SD Card to your PC. Windows may prompt to Format Disk if the SD Card contains other OS, just ignore that by click on Cancel button as this is normal. (Make sure you are not using any data in your SD Card anymore.)

4. Run the "Win32 Disk Imager". Browse and select the "Image File" (e.g. [burn]_open_hour_chameleon_[OS]_[VERSIONS].img) and "Device" (i.e. the SD Card) accordingly.

5. Click on "Write" button to burn the "Image File" to the SD Card. When finished, just plug the SD Card back to the Chameleon and boot.

6. OR, click on "Read" button to read/backup from the "Device" (i.e. the SD Card) and write to the "Image File" specified (this should be a non-existing file).
Make sure that you have downloaded the correct format for burning as each firmware has differing formats so you need the correct one for burning onto the card not the one that you use to simply update the firmware. If you've downloaded the wrong version you can correct it:
http://wiki.openhourlab.com/index.php/Co...D_Card_Img
However get the right .img file in the first place. This one should work fine:
http://files.syabas.com/openhour/android...1.0.27.zip

Follow the steps above and then try the card again.

Then go fix the MAC code. Don't confuse Android Advanced Settings with some special android ohc stuff its simply the Settings that you see when using any android device with a few extra ones for video display.

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
[+] 1 user says Thank You to chris57 for this post
09-10-2015, 11:19 PM
Post: #5
RE: Problem running Android/Open Hour
(09-10-2015 09:17 PM)chris57 Wrote:  -

Thanks!
Well, I were very stupid I must confess :$ Always the fault: the downloads were .zip files, and well.. I have copied zipp files, yes had to unzip them :$
Stupid losen hours Wink But Thanks!
Find all posts by this user
Add Thank You Quote this message in a reply
09-14-2015, 10:58 PM
Post: #6
RE: Problem running Android/Open Hour
Glad its sortedSmile

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Android 5 & 6 on Chameleon Chameleon User 10 2,932 08-12-2016 09:47 AM
Last Post: tosh123
  Problem with 16GB card for Android? sptkyle 6 3,519 06-27-2015 09:43 AM
Last Post: chris57
Information Why do the Android apps not update Blackhalo 3 2,072 05-17-2015 01:33 PM
Last Post: Willem55
  Basic rooted Android OS senaptec 7 6,782 03-29-2015 03:29 PM
Last Post: ottix22
  Xposed framework - tweak your android OS chris57 0 1,215 03-11-2015 12:57 AM
Last Post: chris57
  Get a list a running apps on the OH goodklaatu 1 1,426 03-08-2015 06:55 PM
Last Post: schumaku
  Broken Android SD card images unrealdtc 6 4,424 02-19-2015 11:35 PM
Last Post: F6B_Rider
  Best practice setup for android and SPMC FW 1.0.7 Willem55 17 13,715 12-27-2014 08:54 PM
Last Post: Willem55
Exclamation Problem play files (freeze) Image and Sound nickjack-pt 13 8,736 11-28-2014 12:07 AM
Last Post: F6B_Rider

Forum Jump:


User(s) browsing this thread: 1 Guest(s)