Firmware: Chameleon (1.0.41) Firmware [18 APR 2016] | Gecko (20151106) Firmware [13 NOV 2015]


Post Reply 
VC1 files will not play smoothly
08-19-2015, 07:48 PM (This post was last modified: 08-22-2015 05:59 PM by canaan.)
Post: #1
VC1 files will not play smoothly
I'm just trying to get my head around the 23 976 issue:

So far I have found that all of my 23 976 files play fine when the codec is H 264. However when playing remuxed VC1 files at 23 976 is when I experience slow play and tons of dropped frames.

Is this the issue that others are experiencing with 23 976 or is my situation unique?

for example, this file plays fine (in native player of course):


Apollo 13 1995 4K Remaster BluRay Remux 1080p AVC DTS HD MA 5.1 BMF mkv Wrote:General
Format : Matroska
Format version : Version 4 Version 2
File size : 28.2 GiB
Duration : 2h 19mn
Overall bit rate mode : Variable
Overall bit rate : 28.8 Mbps


Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High at L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Codec ID : V MPEG4 ISO AVC
Duration : 2h 19mn
Bit rate mode : Variable
Maximum bit rate : 29.0 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23 976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Title : MPEG4 AVC Video - 23998 kbps - 1080p - 23 976 fps - 16:9 - High Profile 4.1
Language : English
Default : Yes
Forced : No

But this one jumps and drops frames:

Jurassic Park 1993 Blu-Ray 1080p DTSHDMA7.1 VC1 REMUX FraMeSToR Wrote:General
Format : Matroska
Format version : Version 2
File size : 29.9 GiB
Duration : 2h 6mn
Overall bit rate : 33.8 Mbps

Video
Format : VC-1
Format profile : AP@L3
Codec ID : WVC1
Bit rate : 31.5 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate : 23 976 fps
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive

EDIT: Forum keeps telling me I am inserting URL's when I try and post the mediainfo which I'm not Sad

EDIT2: as below, I had to convert my VC1 files to x264 in order for them to play smoothly. they work fine now, but this is a real pain since vc1 is quite common for uncompressed movies. cloudmedia - please correct the VC1 issue! Smile
Find all posts by this user
Add Thank You Quote this message in a reply
08-19-2015, 09:54 PM
Post: #2
RE: is my problem the 23.976 issue?
You cannot post URL's until you've hit 10 posts. Use spaces and I'll edit.

23.976fps is fixed if you remux into a BD ISO using TSMuxerGUI. If the BD ISO works fine then yes its the same issue.

However VC1 I recall reading over at Freaktab has never and still does not play well on Rockchip players. Have a search for what I'm recalling over at Freaktab as it could be that it does not play well in Kodi on RK players not specifically RK alone. Have a research and go with AVC in your encoding if VC1 is an issue..

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
[+] 1 user says Thank You to chris57 for this post
08-19-2015, 11:50 PM
Post: #3
RE: is my problem the 23.976 issue?
thanks for your reply chris57

yeah I wasn't actually posting any URL's, when I type "23,976" with a full stop it gets flagged as a url, weird.

I will attempt to remux into an ISO as well as looking at Freaktab for info into VC1 not playing well on Rockchip players. I have a hunch that you're right on that issue.

I think I'll be joining the growing number of frustrated users with the OHC. I was so excited to run Kodi, but this is getting old Sad
Find all posts by this user
Add Thank You Quote this message in a reply
08-20-2015, 07:28 AM (This post was last modified: 08-20-2015 11:33 AM by Willem55.)
Post: #4
RE: is my problem the 23.976 issue?
according to a post over at freaktab rockchip can't handle VC1. sigh. rockchip sucks.

amclean123 Wrote:Make sure it does not say VC1 in the upper left hand corner. Rockchip can't handle VC1 movies. If it is a VC1 movie use Handbrake to convert it to H264.

http://freaktab.com/forum/tv-player-supp...pmc/page20
Find all posts by this user
Add Thank You Quote this message in a reply
[+] 1 user says Thank You to canaan for this post
08-21-2015, 12:02 AM (This post was last modified: 08-22-2015 11:00 AM by chris57.)
Post: #5
RE: is my problem the 23.976 issue?
Thought it twigged a recollection of something over there.

I can only agree Rockchip and Android seem to be anything but a match made in heaven presently on support and as an OS in general. The VC1 can be resolved by encoding to AVC as you are encoding in any case but the general performance the foundations are still struggling.
Some software like Kodi for my setup helps resolve some problems and make it a Kodi player which is what the purpose was as there's always been a demand for a Kodi compatible player from CM. For my simple downmix to stereo with addons that stream without any stutter its now finally workable as my daily player. No audio ddddisco/gaps/stutter, appreciate passthorugh is till not there. I only got it working 100% using the supplied SD card (cache issues with high speed cards and USB I/O drivers perhaps?) and from Kodi 15.0 onwards. Just updated to 15.1 and all still good, watched a pre-season NFL game on it and my daily TV downloads.

However as owners we've always wanted a Sigma based Kodi or Openelec setup as nirvana but although there were rumours once that a Sigma chip with Kodi ability was coming it never materialised and now with the recent press and attacks on Kodi form the big USA and UK conglomerates its never going to get the support for the higher end demands for things like 3D, Atmos, HD audio, etc. without the community doing as much as they can without the assistance of the big boys in chip manufacturing that can bring the higher end AV features like HD audio, full 3D, Atmos passthrough, VXP processing etc.

Not saying Sigma are quicker to fix issues though again we suffer like we do with Rockchip. IKt's equally frustrating and its equally frustrating getting news from CM.

There are some 23.976 and other fps test files I posted in a thread with the fps in the title, have a test with them as the 23.976fps may be AVC. Just watched 23.976fps 1080p dimension TV download which was really good for playback.

There is an instruction from OHC to disable autoframerate presently and set output to 1080p/60. This will intriduce stutter on none 60Hz files but not at the same level as the stutter you'll see if you use autoframerate. Remember there's two settings for this one in the Android > Display menu and then if using Kodi one in there aswell.
I'm testing using autoframerate but I'd suggest using the 1080/60 with it off as your baseline and then seeing what you observe when trying to use it. Obviously CM appreciate that for stutter free autoframerate hasd to be working.
The 23.976fps stutter is MKV only, so BDISO should be fine, interested to see if you observe the same.

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
[+] 1 user says Thank You to chris57 for this post
08-21-2015, 05:31 PM
Post: #6
RE: is my problem the 23.976 issue?
yeah I can't say that the whole thing is a disaster, I'm just frustrated so I vent. but I digress

as a whole I like the interface and the fact that I can run Kodi with various skin's. That's a huge plus in my book and all of my friends are very impressed by the interface when I show it off. I guess my (and perhaps others) expectations were that these players would be able to play everything, which I think isn't an unfair expectation given the way that CM market their devices. But when HD audio doesn't operate in the kodi player as could be reasonably expected, and VC1 isn't supported I think that is reason enough for many people to be upset. I recently acquired 8 remux files and 5 are vc1 which won't play. now I have to convert them all which takes ages. granted from now on I'll only get H264/AVC files but thats a huge percentage of high quality files that wont play on this device natively (admittedly it's a small sample size)

I just recently built a home theatre with a 100" screen and 7.1 sound so of course I want the best sound and video which is why I get remuxes and when the OHC can't play more than 50% of the files I get, it makes me wonder why I paid $250 for it. granted if I get 1080p mkv's in x264 there is no issue. I might just go back to buying blu-rays rather than put up with having to convert every VC1 file, it's just not worth the headache, and isn't what I expected out of the device. it's just a real shame to have to go back to physical media to get the quality like Atmos, HD audio like you suggested.

anyway, I digress again.
i converted a VC1 file to x264 last night so I'll try that tonight.
i'll also look up your test files to see if I can accurately diagnose my issues.
i'll also look into the auto framerate issue and set it to 1080/60 manually to see if that resolves any stuttering.

on another note, I do appreciate your responses and always seeing your help here and in the original PCH forums. mods do a lot of unrecognised and hard work that isn't appreciated. so many thanks for that. well done.

p.s. not sure what you mean by the "PGS in MKV" issue.
Find all posts by this user
Add Thank You Quote this message in a reply
08-22-2015, 12:22 AM
Post: #7
RE: is my problem the 23.976 issue?
updates: I tested the file I converted from VC1 to x264 and it plays fine. no skipping and only a couple of dropped frames.
so at this point I believe it to be an issue with Rockchip and VC1 that people on freaktab were mentioning.
also, checked my device and I already had it set to 1080p/60hz and frame rate sync was off.
Find all posts by this user
Add Thank You Quote this message in a reply
08-22-2015, 11:11 AM
Post: #8
RE: is my problem the 23.976 issue?
PGS/MKV was another app I cannot use native player and was testing differing apps. Kodi works great for subs on all test files including PGS, apologies for taking you off tack.

I personally don't see Kodi(lack of HD, 3D, etc.) or Rockchip players (no VXP, not known for PQ) as being premium or high end. The PCH/NMT is the premium CM brand but that's not high end either, however due to the Sigma chip does give more high end features. The OHC is more of a miniPC to me which is great as its does so much more than just being a set top box. But as we all know there are advantages to specialising that are traded away.

I don't think we have had a thread on the RK/VC1 issue, have a search to see. If not perhaps retitle your thread and lets try to push it a bit.

OHC > HDMI > TV (Panasonic 42G20)
Downmix stereo using standard Kodi(MC) 15.2 no hware/acc OK
Downmix stereo 1.0.40/RK Kodi(RKlib) 15.2 infrequent audio gaps hware/acc OK

No DTS downmix available for inbuilt eMC player

Gecko> HDMI > TV (Panasonic 42G20)
Downmix stereo using Gecko Kodi 15.0 OK
Downmix using inbuilt MediaCentre OK

Find all posts by this user
Add Thank You Quote this message in a reply
08-22-2015, 06:01 PM
Post: #9
RE: VC1 files will not play smoothly
yeah if you think of it that way it does make more sense. however, I still think its disappointing.
I've updated the thread title for more visibility of the issue.
Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Can't play 4K file ptnafe 13 4,935 11-25-2015 06:15 AM
Last Post: chris57
  Can you play 10bit or Hi10 mkv's on this player? Bloodsack 20 18,828 04-25-2015 05:30 AM
Last Post: Wanbyn
  No sounds when play with native player hkfires 2 1,449 01-21-2015 06:32 PM
Last Post: btezB
  Google Play Store : Unable to install application. Drago 7 3,215 12-18-2014 07:37 AM
Last Post: Maria_Kylie
  Is Open Hour can play Bluray 3D ISO files and/or MKV 3D ? HappyGoLucky 0 2,007 11-24-2014 10:56 AM
Last Post: HappyGoLucky
  Dropping files onto the Chameleon skarg4 5 2,790 11-11-2014 01:31 PM
Last Post: codemonkey76

Forum Jump:


User(s) browsing this thread: 1 Guest(s)